Yeastar P520

Free · Visible Calling Experience

Supports 20 extension users, up to 4 analog extensions, 4 analog trunks. Efficient communication with simple management, no dedicated IT staff required.

20
Users
10
Concurrent Calls
4
FXS Ports (max)
4
FXO Ports (max)
Yeastar P520
01

Efficient Communication

Web-based voice/video calls with a visual call interface, making communication more intuitive and efficient.

02

Simple Management, No Dedicated Staff Required

New UI backend with clear guided setup, user-friendly interface. No need to hire dedicated maintenance staff. Network-based voice transmission eliminates traditional phone wiring constraints.

03

Rich Features, Driving Enterprise Growth

Covers basic voice features, enterprise communication features, and subscription/licensing features, meeting daily communication needs while enhancing internal and external communication efficiency.

Basic Features

Inbound Routing
Outbound Routing
Call Waiting
Call Pickup
Call Hold
Call Park
DND
Three-way Call
Simultaneous Ring Mobile
Barge/Whisper
Missed Call Email Alert
Custom Prompt
Intercom
Call Transfer (Consultative/Blind)
Call Forward (No Answer/Busy/Unconditional)
Extension Status
Video Call (1-on-1)

Advanced Features

Conference Room
Call Recording
Call Log
Speed Dial
Ring Group
Auto Attendant
Org Chart
Auto Provisioning
Enterprise Directory
LDAP/LDAPS
ACD
Shared Voicemail
Distinctive Ring
Time Condition
Smart Inbound Match
Voicemail
Broadcast Group
Scheduled Broadcast
Call Queue
Satisfaction Survey
Dynamic/Static Agent
SLA
QCB
Popup URL
Hot Standby
T.38/T.30 Fax
Fax to Email
BLF (Web/Google Extension)
CTI
File Sharing (Samba/FTP/TFTP)

Value-Added Features

Operator Panel
Queue Console
Queue Dashboard
Call Report
Voicemail Transcription
Video Conference
Pro Directory
API Service
CRM Integration
FQDN
Billing Report
Tunnel Service
Tunnel Service Upgrade
Mobile Linkus
Web Linkus
Linkus Google Extension
Instant Messaging

System Security

Country IP Defense
Outbound Frequency Limit
Extension Binding
International Call Defense
Firewall
IP Blocklist
Static IP Defense
Auto IP Defense
SRTP Encryption
TLS Encryption

Capacity

Users20
Concurrent Calls10
FXS Ports (max)4
FXO Ports (max)4
VoIP Trunks50

Hardware

Network Ports2 × 10/100/1000 Mbps
TF Card1
PowerDC 12V 1A
Dimensions (W×D×H)160 × 160 × 30 mm
Weight0.3 KG
InstallationDesktop

VoIP

ProtocolSIP (RFC3261)
Transport ProtocolUDP, TCP, TLS, SRTP
Voice CodecG711(alaw/ulaw), G722, G726, G729A, GSM, Speex, ADPCM, iLBC
Video CodecVP8, H263, H263P, H264, MPEG4
DTMFIn-band, RFC4733, RFC2833, SIP INFO

Frequently Asked Questions

Interested in this product?

Contact our sales team for pricing and consultation